Overview
In Expertise Insights, you create analyses, then publish them as dashboards to share them with other users. You can edit an analysis without affecting the published dashboard and what other users see.
Analysis Editor User Interface
The key components of the analysis editor are as follows:
- Menu
- Analysis actions
- Analysis toolbar
- Left panels
- Sheet tabs
- Canvas (sheet)
- Right panels
1. Menu
The following sections and actions are available in the menu at the top:
- Home—Select the purple and pink icon to return to the homepage, which may be the dashboards list, analyses list, or your favorites.
- File—Includes options to favorite, publish, save, share, rename, import content, print, export, and turn autosave on or off.
- Edit—Includes options to undo and redo, apply themes, and update the analysis settings.
- Data—Includes options to manage the datasets for the analysis, add calculated fields, and manage parameters.
- Insert—Includes options to add sheets, add visuals and visual elements, and add calculated fields, filters, and parameters.
- Sheets—Includes options to add, duplicate, and rename sheets; add a sheet title and description; and configure the sheet’s layout settings.
- Objects—Includes various configuration and style options for visuals and visual elements, such as title, data labels, conditional formatting, tooltips, interactive actions, and more. You can also export visuals from this menu.
- Search—If you can’t find the action you want to perform, use the Search in the menu to quickly find an action.
2. Analysis Actions
On the left side of the analysis action bar are the following options:
- Favorite or unfavorite the analysis
- Rename the analysis
On the right side of the analysis action bar are the following options:
- Turn Autosave on or off
- Make the analysis Fit to width or display the Actual size
- Publish the analysis as a dashboard. Once published, you can share the dashboard with other users to give them access to it.
3. Analysis Toolbar
The following options are available in the analysis toolbar:
- Undo
- Redo
- Datasets—Opens or closes the Data panel on the left, where you can manage the datasets in the analysis, add calculated fields, and add or remove fields from visuals.
- Sheet contents—Opens or closes the Sheet contents panel on the left, where you can see and search for the visuals and visual elements in the current sheet.
- Visualize—Opens or closes the Visuals panel on the left, where you can configure the currently selected visual. See the Visuals Overview article for more information.
- Filters—Opens or closes the Filters panel on the left, where you can configure filters for the analysis or individual visuals.
- Parameters—Opens or closes the Parameters panel on the left, where you can add and configure parameters.
- Insights—Opens or closes the Insights panel on the left, where you can see a list of AI-generated suggested visuals and add them to the analysis.
- Properties—Opens or closes the Properties panel on the right, where you can configure settings for the currently selected visual, visual element, or filter. See the Visuals Overview article for more information
- Add—Provides options to add visuals and visual elements to the analysis. See the Visuals Overview article for more information.
4. Left Panels
The following panels open to the left side.
- Data panel—Displays the list of available fields and allows you to manage the datasets for the analysis, add fields to visuals, and configure and style fields for all visuals. You add fields to a visual by dragging them from the Data panel and dropping them into a section in the Visuals panel.
- Add calculated field panel / Edit calculated field panel—Allows you to create and edit calculated fields, which are data fields transformed by mathematical operations, conditional logic, string manipulation, and more. You can use AI to create and edit calculated fields.
- Sheet contents panel—Allows you to see and search for the visuals and visual elements in the current sheet.
- Visuals panel—Allows you to change the visual type and manage and configure the fields for the currently selected visual. More visual configuration options are available via the visual options in the canvas and the Properties panel to the right.
- Parameters panel—Allows you to configure parameters, which let you to dynamically control values in fields, filters, and sheets.
- Filters panel—Allows you to configure filters, which can apply to individual visuals, an entire sheet, multiple sheets, or all sheets.
- Insights panel—Allows you to view and add AI-generated suggested visuals.
5. Sheet Tabs
The list of sheets is displayed in a tab above the canvas. You can add, rearrange, rename, duplicate, and delete sheets from this area.
6. Canvas (Sheet)
You add visuals and visual elements to the sheet, i.e. the “canvas” of the analysis. Select an item on the sheet to access the visual options in the canvas. You can resize and rearrange the items on the sheet.
7. Right Panels
The following panels open to the right side.
- Properties—Allows you to configure a visual.
- Format control—Allows you to configure the interactive element for a filter.
- Conditional formatting—Allows you to configure conditional formatting for a field.
How to Create an Analysis With AI
With Expertise Insights, you can create an analysis (i.e. dashboard) in just minutes using natural language. Just select datasets to act as data sources, describe the dashboard that you want, and an analysis filled with visuals, filters, and key metrics is created within minutes.
- In the left navigation, hover over Insights, then select Advanced Editor. The Advanced Editor opens in a new tab.
- In the left menu, select Analyses.
- Select Generate analysis.
- Select Add data.
-
In the modal that opens, select the datasets to use for the dashboard. Datasets provide the underlying data for dashboards.
Tip: See the Standard Datasets Overview article for information about the standard datasets - Select Add.
-
Enter a prompt describing the dashboard you want to create.
Tip: You can include the business questions that you want answers for, the metrics that you’re interested in, and how you want the information organized across sheets.
Example prompt: Create a time dashboard showing where people logged time on different types of projects, time logged by top level tasks, and time trends. Include metrics for billable utilization, productive utilization, and unlogged time. - Select Generate analysis to generate the analysis immediately.
- or -
Select Preview analysis outline to generate an analysis outline, which is a proposal document describing the analysis that will be built. You can review and edit the analysis outline before actually generating the analysis. - If you generated an analysis outline, review and edit the outline, then select Generate. The analysis is generated. The process may take a few minutes to complete.
- Once completed, the generated analysis opens.
- You can edit the analysis and individual visuals.
- You can Publish the analysis as a dashboard. Once published, the dashboard can be shared with other users.
How to Create an Analysis from Scratch
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Analyses from the left menu.
- Select the New analysis button to the upper-right.
- Select a dataset to use as the data source. We recommend choosing one of the standard datasets. You can add more datasets to the analysis later, if needed.
The dataset page opens. - Select the Use in analysis button to the upper-right. The analysis editor opens.
- To rename the analysis:
- Click into the field to the upper-left.
- Enter a new name.
- Press Enter on your keyboard or click outside of the field.
- Add and configure visuals, visual elements, filters, and calculated fields.
- When Autosave is on, your changes are saved automatically. Published dashboards are not affected when the analysis is updated.
- Select Publish to publish the analysis as a dashboard. Once published, the dashboard can be shared with other users.
In Expertise Insights, custom fields are in separate datasets. You can add custom field datasets to an analysis to make custom fields available to add to visuals.
- Select the Datasets icon in the toolbar. The Data panel opens to the left.
- Select the Data menu.
- Select Manage data in the drop-down menu. The Manage data modal opens.
- Select Add data.
- Select a custom field dataset. The datasets are named using the following format:
- standard_ox_{account_id}_cf_story—Task custom fields.
- standard_ox_{account_id}_cf_user—User custom fields.
- standard_ox_{account_id}_cf_workspace—Project custom fields.
- standard_ox_{account_id}_cf_workspace_group—Group custom fields.
- standard_ox_{account_id}_cf_resource—Resource custom fields.
- Select the Select button. A message appears in the modal to indicate that the dataset was added successfully.
- Select the Close icon to the upper-right of the modal. The fields list in the Data panel now includes custom fields.
How to Add a Filter to an Analysis
You can filter a single visual, a whole sheet, or multiple sheets. Once a filter is added, you can add a UI element for the filter—known as a control—to allow dashboard viewers to interact with the filter.
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Analyses from the left menu, then select an analysis from the list.
- Select a visual in the canvas. If you would like to add a filter that applies to the entire dashboard, this can be configured in a later step.
- Select the Filter icon in the toolbar. The Filters panel opens to the left.
- Select the Add button in the Filters panel.
- From the drop-down menu, select a field to filter by. The filter is added to the Filters panel. By default, the filter applies to only the selected visual.
- To configure the filter:
- Select the More icon for the filter.
- Select the Edit menu option.
- In the Applied to section, select the item(s) the filter should apply to:
- Single visual—The filter applies to only the selected visual.
- Single sheet—The filter applies to all visuals in the current sheet.
- Cross-sheet—The filter applies to all visuals in multiple or all sheets.
- See the following external articles for information about the available filter configuration options:
- Text filters (i.e. dimensions)
- Numeric filters (i.e. measures)
- Date filters
- Select the Add filter condition button to configure multiple filters that are applied with OR logic.
- Select Apply. The filter is applied and the visual(s) update.
- Select the Back icon at the top of the Filters panel to return to the list of filters.
- To add the filter as a control—allowing users to interact with the filter—complete the following steps:
- Select the More icon for the filter.
- Hover over the Add control menu option.
- Select Top of this sheet or Inside this sheet.
- If the filter is for a measure field, an Add control modal will appear.
- Enter a Name for the filter.
- Select a Style for the interactive element.
- Configure the options.
- Select Add.
- To configure the filter control:
- For a control at the top of the sheet:
- Select the Expand icon to the right of the Controls section to expand the Controls section.
- Hover over the control.
- Select the More icon to the upper-right of the control and select the Edit menu option. The Format control panel opens to the right.
- For a control inside the sheet:
- Hover over the control.
- Select the Format icon to the upper-right of the control. The Format control panel opens to the right.
- Configure the options in the Format control panel:
- The Title section includes options for the filter control’s name and help tooltip.
- The Control options section includes options for the style of the interactive element and related settings.
- The Sort section includes options for sorting and aggregation.
- The Style section includes options for padding.
- The filter control updates as you make changes in the Format control panel.
- For a control at the top of the sheet:
How to Publish an Analysis as a Dashboard and Share the Dashboard with Users
In Expertise Insights, you create analyses, publish them as dashboards, then share dashboards to grant access to other users.
To publish an analysis:
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Analyses from the left menu, then select an analysis from the list.
- Select Publish in the upper-right of the analysis. The Publish dashboard modal opens.
- If you’re publishing the analysis for the first time, the New dashboard tab will be selected. If you’re re-publishing an analysis, the Replace existing dashboard tab will be selected and the Dashboard name will be populated automatically.
- For new dashboards, enter a Dashboard name.
- Add notes. The notes will be visible in the dashboard version history. Notes are optional.
- In the Select sheets drop-down menu, choose which sheets should be published.
- In the Generative capabilities section, check Allow executive summary if you would like users to be able to generate executive summaries of the dashboard sheets.
- In the Data snapshot options section, check Allow sharing stories if you would like users to be able to include visuals from this dashboard when creating stories.
- Select the More Settings button to configure additional options:
Dashboard options | |
| Expand top of sheet controls panel by default | If checked, the Controls section is expanded by default. Leave this unchecked to provide a cleaner view of the dashboard. |
| Enable ad hoc filtering | If checked, users can add, edit, disable, and enable dashboard and visual-specific filters in their view. |
| Enable on-hover tooltip | If checked, hover tooltips are activated. |
| Enable print | If checked, users can print the dashboard. |
| Enable on-demand PDF generation for interactive sheets | If checked, users can generate and save a PDF of the dashboard. |
Visual options | |
| Enable maximize visual option | If checked, the Maximize button is available for visuals, which makes the visual fit the width of the dashboard, allowing users to see information better. |
| Enable visual menu | If checked, icons appear to the upper-right when users hover over a visual, providing access to options such as alerts, customization, sorting, drill up/down, and more. |
| Enable on-demand export to CSV and Excel for interactive sheets | If checked, visuals can be exported as CSV or Excel files. |
| Enable export of hidden fields on supported visuals | If checked, hidden fields may be included in exports of visuals. |
Data point options | |
| Enable drill up/down | If checked, users can drill up to a higher level or drill down to more granular levels for visuals that support drill actions. |
| Enable on-click tooltip | If checked, tooltips appear when users click on a data point. |
| Enable sort options | If checked, sorting controls are available. |
- Select Publish dashboard. The dashboard opens.
To share a dashboard:
- From the dashboard, select the Share icon in the upper-right of the toolbar, then select Share dashboard.
- To share the dashboard with all users who have access to Expertise Insights:
- Toggle the Enable access for: Everyone in this account option to the On position.
- To share the dashboard with specific users:
- Search for a user by their email address in the Invite users and groups to dashboard section.
- For a user in the list, select the Add button.
-
Choose a permission level for the user: Viewer or Co-owner.
Note: Only users with an Author license type can be made co-owner of a dashboard. - The user is added to the Users & Groups section and can now access the dashboard.
- To remove a user’s access to a dashboard, select the Delete icon for that user in the Users & Groups section.
How to Revert a Dashboard to an Earlier Version
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Dashboards from the left menu, then select a dashboard from the list.
- Select the Version history icon to the upper-right of the dashboard. The Version history panel opens to the right.
- Select a version from the list.
- Select the Publish button to re-publish that version.
- Select Confirm in the modal that opens.
How to Clone an Analysis or Dashboard
To clone an analysis:
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Analyses from the left menu, then select an analysis from the list.
- In the menu bar, select File > Save as Analysis. The Save a copy modal opens.
- Enter an Analysis name.
- Select Save. The new analysis opens.
To clone a dashboard:
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Dashboards from the left menu, then select a dashboard from the list.
- Select the Save as icon to the upper-right of the dashboard. The Save as analysis modal opens.
- Enter an Analysis name.
- Select Save. The new analysis opens.
How to Delete an Analysis or Dashboard
To delete an analysis:
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Analyses from the left menu.
- Select the More icon for an analysis.
- Select Delete.
- Select Delete in the confirmation modal.
To delete a dashboard:
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Dashboards from the left menu.
- Select the More icon for a dashboard.
- Select Delete.
- Select Delete in the confirmation modal.
Working with Visuals in an Analysis
Visuals (i.e. reports) and visual elements are the main content of analyses and dashboards. You create and edit visuals while editing an analysis.
You can configure visuals in various ways, including adding conditional formatting, adding tooltips, configuring drill up and down interactions, formatting fields, configuring styling, and more.
For more information, see the Visuals Overview article.
How to Add a Calculated Field to an Analysis
You can create calculated fields to transform data in various ways, including applying mathematical operations, conditional logic, string manipulation, and more.
- In the left navigation, hover over Insights, then select Dashboards Home.
- Select Analyses from the left menu, then select an analysis from the list.
- Select the Datasets icon in the toolbar at the top. The Data panel opens to the left.
- Select the Calculated field button below the Search fields search bar. The Add calculated field panel opens to the right of the Data panel.
-
Enter a Calculation name.
Tip: You can prefix your calculated fields with a special character (e.g.!) to differentiate them from Kantata-provided fields and to group them together in the alphabetic field list. - To create a calculated field with AI:
- Select the Build with AI icon.
- Describe the calculated field.
- Select the Send icon.
- The formula editor updates with an AI-generated formula.
- To create a calculated field manually:
- In the Build tab, start entering a formula in the formula editor.
- Select the Insert items icon above the editor to add Functions, Fields, and Parameters to your formula. For information on the available functions and operators, see the Calculated field function and operator reference external article.
- Select Save.
The calculated field now appears in the Data panel and can be added to visuals. - To edit a calculated field, select the More icon for the calculated field in the Data panel, then select the Edit menu option. The Edit calculated field panel opens to the right of the Data panel.
Once a calculated field is in use, you can see which visuals, calculations, or filters the calculated field is used in by accessing the Usage tab within the Edit calculated field panel. This information helps you understand which items will be impacted when you edit or remove a calculated field.
Comments
0 comments
Please sign in to leave a comment.