General troubleshooting guidance and solutions to common issues for the Smart Upload Manager.
ACCESS AVAILABILITY
The Smart Upload Manager is an additional feature for Kantata OX. For access, please contact Customer Success.
SMART UPLOAD MANAGER TRAINING COURSES
To assist you in learning more about the Smart Upload Manager, visit the Smart Upload Manager Training Courses.
Overview
This article provides general troubleshooting guidance for the Smart Upload Manager (SUM) as well as solutions to common issues.
General Troubleshooting
The general troubleshooting steps are as follows:
- View error log (in SUM or the CSV export)
- Fix the rows with errors
- Replace the CSV file or upload the fixed CSV file
When a blueprint has the Validated with errors status, the data sets with errors will have an orange Review icon beside the tab name, while the data sets without errors will have a green Validated icon.
When a blueprint has the Processed with errors status, the data sets with errors will have an orange Review icon beside their tab name, while the data sets that processed without errors will have a green Processed icon.
Select a data set tab to view the errors for that data set.
View Errors in SUM
Viewing the errors within SUM is recommended when there are only a few errors in the data set.
Rows with errors can be identified by the Error
icon that appears to the left.Click the Error
icon to view the error details for that particular row.View Errors in CSV Export
Exporting the CSV file from SUM is recommended when there are a lot of errors. This makes it easy to identify and fix many rows at once.
Above the data set table are two export options:
- Export Data Set—This will provide an export of the entire data set with an additional column for the error logs. Select this option if the blueprint has the Validated with Errors status.
- Export Errors—This will provide an export including only the records that failed to process and with an additional column for the error logs. Select this option if the blueprint has the Processed with Errors status.
Once exported, open the CSV file. Each row with an error will have an error message in the error_logs
column.
You can refer to the Smart Upload Manager Data Set Templates for detailed information on field types and example values.
Fix Rows with Errors
For every row with a value in the error_logs
column, update the data and fix the cause of the error. When finished, remove the error_logs
, processed
, and native_id
columns from the CSV file.
Replace CSV File or Upload Fixed CSV File
Once you have fixed all of the rows with errors and removed the extra columns, the next step depends on the blueprint’s status. You must either replace the CSV or create a new blueprint.
- If the blueprint has the status Validated with Errors:
- On the data set page, select Replace. This will reset the data set.
Once the data set has been reset, a notification will appear in the upper right. - Upload the CSV file. You must upload the original CSV file—with all rows—with the errors fixed.
- On the data set page, select Replace. This will reset the data set.
- If the blueprint has the status Processed with Errors:
- Create a new blueprint.
- Upload the CSV file containing only the fixed rows. Do not include the rows that had no errors; otherwise, the objects will be duplicated.
Troubleshooting Common Exceptions
This section outlines common errors encountered in SUM and how to fix them.
Issue: ["Not Found"]
Object Type: | All Objects. |
Potential Cause: |
|
Solution: | Please provide appropriate objects (e.g. user, task, or project) into the CSV file. |
Issue: Effective_date must be given in ISO-8601 format (YYYY-MM-DD)
Object Type: | All Objects. |
Potential Cause: | The date is not formatted according to the Smart Upload Manager requirements. |
Solution: | Look up the date format in Smart Upload Manager Data Set Templates. In most cases, dates should be entered as YYYY-MM-DD . |
Issue: Required field is missing
Object Type: | All Objects. |
Potential Cause: | All required fields need to be filled out within the CSV file. |
Solution: | Certain fields are required for each scenario in order to import the data into Kantata OX correctly. Please refer to the Smart Upload Manager Data Set Templates document to see which fields are required. |
502 Bad Gateway
Object Type: | All Objects. |
Potential Cause: | A temporary network issue with Kantata OX. |
Solution: | Try the request again at a later time. You may need to use the Export Errors option and reload the data that failed. |
504 Gateway Time-out
Object Type: | All Objects. |
Potential Cause: | A temporary network issue with Kantata OX. |
Solution: | Try the request again at a later time. You may need to use the Export Errors option and reload the data that failed. |
Troubleshooting Invoice Data Sets
Uploading invoices via Smart Upload Manager requires the use of the invoice data set and several dependent data sets. If an invoice data set fails for any reason, the dependent data sets most likely also failed. When fixing errors related to invoices, we recommend re-uploading the dependent data sets along with the corrected invoice data set.
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